Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

XAircraft Align M480 & SuperX left drift while on GPS & Attitude mode

Discussion in 'General Drone Manufacturer Discussion' started by traxx2003, Mar 30, 2015.

  1. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Mar 30, 2015 #1
    Hello! I was wondering if someone could tell me if this is normal behavior for the SuperX controller while on GPS mode and or Attitude mode. I'm asking because of the countless videos where people rave about the stability of this FC while on GPS and even on manual mode. On one particular video from a well know pilot from China, he claims that the manual mode of this FC is like flying on Attitude mode. That of course has not been my experience. On the flight from the video my gains where set at 1..1 just like the manual recommends. On subsequent test flights I have gone as high as 1.4 with not changes in flight behavior. If I try some forward flying, at soon as I let go of the controls, there is a 3-4 second delay before the FC starts to counter act the forward momentum to hold position and this is while on GPS hold with 12+ satellites. See video link below:

    Flying conditions: 2mph from east, temp 83

    Equipment:
    Align M480 (stock motors/ESC's)
    Pulse 6S 16,000mah 15C batt
    Futaba 14SGH
    Gains: 1.0 across like the manual recommends.

    Video Link:
    Super X Flight Controller Left hand drift while on GPS or Attitude Mode (1 min 44 sec)
     
    Tags:
  2. synrg

    synrg Member

    54
    2
    0
    Jun 7, 2014
    Orlando, FL
    Posted by synrg, Mar 31, 2015 #2
    XScope configuration?


    Sent from my iPad using Tapatalk
     
  3. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Mar 31, 2015 #3
    Synrg, i currently have it set as a quadcopter. I friend of mine has the same quad I have with the SuperX, setup as a Quadcopter on the software and his quad flies great.
     
  4. X650Mouse

    X650Mouse Take no prisoners

    438
    10
    1
    Nov 13, 2013
    Australia
    Posted by X650Mouse, Mar 31, 2015 #4
    Okay, in GPS hold mode it should be like painted on the sky, and provided thrust stick is at 50% you can put down the radio, with Attitude hold mode it will maintain a distance from the ground but will drift due to external elements such as wind, in manual mode all aspects of flight need to be attended too as no sensors control the vehicle.

    I would suggest you get your black box log and post a link here so we can see what is going on.

    Here is a short video I did for some other inquiring on the SuperX features, this is with a XA X650 Pro.

    X
     
  5. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Mar 31, 2015 #5
    X
    650
     
  6. X650Mouse

    X650Mouse Take no prisoners

    438
    10
    1
    Nov 13, 2013
    Australia
    Posted by X650Mouse, Mar 31, 2015 #6
    Your Black Box will help

    X
     
  7. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Mar 31, 2015 #7
    I'm at work, will post report tomorrow.
     
  8. synrg

    synrg Member

    54
    2
    0
    Jun 7, 2014
    Orlando, FL
    Posted by synrg, Mar 31, 2015 #8
    X650Mouse do you recommend the Quadcopter (X) or the Xcope profile for the ALIGN M480L? I'm setting up an M480 with SX as well.
     
  9. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Mar 31, 2015 #9
    Synrg, right at this moment I cannot recommend which is best, as I'm currently trying to resolve the problems that I have with my setup. But I will definitely ask tech support to see what they recommend. I'll keep you posted.
     
  10. Mike SF

    Mike SF Banned

    53
    0
    1
    Posted by Mike SF, Mar 31, 2015 #10
    There is definitely something wrong. Even in heavier wind or with the CG off, it should not roll that fast to the left. Maybe there is a left roll trim?
     
  11. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Mar 31, 2015 #11
    Ok here is the link for a test run, XAircraft asked me to conduct without props on while onATTI mode. They want the date in order to asses if the IMU is bad. I personally think the IMU is definetly bad. Also I recorded the video below while conducting the test run in order to show how while the aircraft being perfectly leveled on the ground, the artifical horizon line from th OSD slowly starts to frift from its level position.

    http://log.xaircraft.cn/#2015_03_31_223817.848_43.1.05.02

    Video link:
     
  12. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Mar 31, 2015 #12
    Today XAircraft asked me to conduct a test run of my aircraft running for five minutes on the ground while on ATTI mode without props and throttle @ 50%. I guess they want to use the log file to asses if the IMU is doing what is suppose to. I personally think my IMU is bad. Below are the links for the log file and a video I recorded while conducting the test run. On the video you can appreciate how my artificial horizon line slowly drift from its level position within seconds from powering up. You will also notice how even though the quad is sitting perfectly level, my heading is constantly changing as if the quad was actually in the air. I believe that the horizon line drift and the left hand aggressive drift/bank I am experiencing while flying my quad are directly linked or related. The OSD depends on data from the IMU in order to display information on the aircraft attitude and heading on the monitor. But of course we all know that. Enjoy. I apologize in advance for my poor video recording skills.

    Log file: http://log.xaircraft.cn/#2015_03_31_223817.848_43.1.05.02
    Video link:
     
  13. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 1, 2015 #13
    Update, got an email from XAircraft support asking me to delete the 'STATUS' file located inside the CFG folder. They found some of the parameters to be incorrect. They emailed me a new STATUS file for me to install and if that don't fix my problem, they will exchange my SuperX. At last good news!! Will post again with outcome.
     
  14. synrg

    synrg Member

    54
    2
    0
    Jun 7, 2014
    Orlando, FL
    Posted by synrg, Apr 1, 2015 #14
    That is good news and impressive customer service. Please keep us posted.


    Sent from my iPad using Tapatalk
     
  15. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 1, 2015 #15
    New 'status file' has been installed, my artificial horizon line is level now and the left hand drift appears to be gone. Couldn't really test everything the way I wanted because of high winds today (23 mph +). Anyway here is a link for the data log for a quick five minute hover flight on GPS hold that I did with 23mph winds. Can someone care to take a look and give me their opinion?

    http://log.xaircraft.cn/report.htm#2015_04_02_095007.303_50.2.04.02
     
  16. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 2, 2015 #16
    Update: today I had a chance to really test my updated SuperX and all I have to say is WOW, I flew with a 5-10mph wind and this thing held position like no other FC I've ever seen. The artificial horizon line is level now. So far so good. Next I need to figure out why my OSD will not feed video from camera to my transmitter.
     
  17. synrg

    synrg Member

    54
    2
    0
    Jun 7, 2014
    Orlando, FL
    Posted by synrg, Apr 2, 2015 #17
    That's great. Glad you got it worked out.


    Sent from my iPad using Tapatalk
     
  18. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 6, 2015 #18
    Update: Guys my SuperX is fixed!! The left drift was caused for bad parameters loaded on the IMU. According to XAircraft support, the 'STATUS' file inside the CFG folder had some missing flight parameters. After installing a corrected 'STATUS' file they emailed me, my quad flies like a dream!!!
     
  19. Andre LaFramboi

    Andre LaFramboi Member

    76
    0
    1
    May 17, 2014
    Posted by Andre LaFramboi, Apr 6, 2015 #19
    did you use the align pcu do you have a gimbal and retracts working. Maybe post some pictures i just got the standard version was going to use in my 690 with arris retract controller and castle creation pro.
     
  20. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 17, 2015 #20
    Andre I'm sorry it took this long to reply back! Yes I'm still using the Align PCU, I do not have a gimbal yet since I'm still working on setting up my M480 the way i wanted. I do have working retracts, but with a Tarot gear controller. The Tarot controller accepts 6S voltage without the need for a BEC. I also changed all of the Align motors/ESC's for T-Motors Navigator MN4120, 400kv and T-Motor T60A ESC's with 16x5.4 carbon fiber props also from T-Motor. Give me a week or so, I'll be taking my quad apart in order to relocate the ESC's to the bottom of the frame, having overheating issues with the ESC's mounted inside the frame.
     
Loading...

Share This Page

Loading...