Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

Weird problem with miniquad, pls halp!

Discussion in 'Recreational sUAS Flyers Discussions' started by crg5990, Nov 15, 2014.

  1. crg5990

    crg5990 New Member

    3
    0
    0
    Nov 15, 2014
    Posted by crg5990, Nov 15, 2014 #1
    Hey guys, first post only cause I have a wild problem occurring with my setup. It's a qav250 running the full naze32 fc, afro mini 12a esc with Simon k pre flashed, 4s battery, spektrum ar610 rx with dx6 tx, and lumenier 1806 2300kv motors with gemfan 5x4's. Not sure how relevant any of that is for this problem but just putting it out there.

    Ok so here's the issue: the motors hit what seems like full throttle, at only half stick on the tx. In baseflight the throttle channel and motor test boxes continue to read from 1400 up to 1980 but the motors don't spin up any faster. I've tied everything from calibrating all 4 esc at once in baseflight, calibrating them 1 by 1 directly thru the rx, setting min and max in the cli, setting the tx to try and get mid power at mid stick, and 1 by 1 via motor test. Nothing changed a single thing other than when I calibrated 1 by 1 in motor test, they got slightly better, as in the motors worked exactly as they should, but only 2 of them. The other 2 actually got worse and didn't even turn on untill around 13-1400. Both my friend, who knows much more about this stuff then I do, and I are stumped and any ideas from people would be great. At this point he's thinking something is wrong in the latest firmware for the naze or the Simon k firmware. I managed to bandaid the problem by setting my throttle curve via the tx, but it's almost completely horizontal, and now the fc only reads throttle input up to 1300 which for the motors is full throttle. Here are my throttle curve points:
    1: 0%
    2: 9%
    3: 11%
    4: 15%
    5: 18%
    6: 25%
    7:----
    Not sure if this is normal for mini quads or not, but it doesn't seem right to me. Any help is appreciated!
     
    Last edited by a moderator: Nov 15, 2014
    Tags:
  2. kloner

    kloner Aerial DP

    8,642
    15
    0
    Jan 5, 2012
    San Diego
    Posted by kloner, Nov 16, 2014 #2
    i'm somewhat unfamilliar with naze, but when you were thinking this was happening were you in an altitude hold mode or manual mode on the flight controller? manual mode is the one you'd want to look at this through, usualy a barometer in any other mode starts interacting with your input command and skews it unless your flying it and the barometer reacts

    i'd put the radio back to a 0-25-50-100 config and figure out whats wrong
     
  3. cootertwo

    cootertwo Member

    746
    117
    26
    Oct 29, 2013
    oii0i0i
    Posted by cootertwo, Nov 16, 2014 #3
    I agree with Kloner. Software/firmware is usually the very last thing I'd suspect. Something ain't right, and maybe the easiest way to figger it out is by trying different bits and pieces. The parts you listed "should" work well together, But I have never tried the Afro ESC's. So maybe try (borrow) another Naze board, different ESC's. You said 2 motors seemed to work OK? Try switching those motors with the 2 that don't work right, any difference? Sometimes a newly built rig can have a simple problem cause all kinds of weird things. Sometimes, for me at least, a complete tear down, and reassembly reveals some forgotten wire, or calibration, etc. etc. Let us know when and what you find, that's how we all learn.:tennis:
     
  4. crg5990

    crg5990 New Member

    3
    0
    0
    Nov 15, 2014
    Posted by crg5990, Nov 17, 2014 #4
    It happens in rate and self level modes, I tried a baro hold once and she nearly flew off on me so I haven't used that since lol I'd love to try out another set of esc's or another fc but the only way I'd be able to is if I bought another set. My friend flies larger sized tris and helis so his esc's are too large, nor does he run a naze. I set the tx back to normal throttle curve and this is what I get. This also happens with the bandaided curve, if I change any expo or curve settings in baseflight

    http://youtu.be/xvbzkdzzRnM
     
  5. crg5990

    crg5990 New Member

    3
    0
    0
    Nov 15, 2014
    Posted by crg5990, Nov 18, 2014 #5
    Little bit more to add here, changed the throttle curve on the tx back to normal, and hooked each esc/motor to the rx directly. Rx was unplugged from the fc and after calibration with the tx, each motor individually and all together were still having the issue. Going to try binding my friends dx6i and seeing what happens but I'm not holding out for much. Now I need to figure out if the issue lies in the esc itself, the fact that I have somewhat small motors, or the tx.
     
Loading...

Share This Page

Loading...