Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

XAircraft OSD overlay shows but no video

Discussion in 'General Drone Manufacturer Discussion' started by traxx2003, Apr 2, 2015.

  1. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 2, 2015 #1
    Ok, so now my OSD flight data overlay shows on my monitor, but no video from camera, so far this is what I've done to troubleshoot this issue:
    1. camera cap off
    2. tested camera by connecting it directly to my video transmitter on board the quad, I got clear video feed to the monitor.
    3. inspected connections between the I/O and OSD module, everything seem ok.
    4. check continuity on all of my video wire cables, no broken wires found.

    What else could it be? Anybody ?
     
    Tags:
  2. X650Mouse

    X650Mouse Take no prisoners

    438
    10
    1
    Nov 13, 2013
    Australia
    Posted by X650Mouse, Apr 2, 2015 #2
    You are not having much luck are you? make sure VTX and OSD are both set to NTSC

    X
     
  3. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 2, 2015 #3
    No luck at all! Yes they are. My video xmitter is the ImmersionRC 600mw, I believe ntsc is default setting on it.
     
  4. traxx2003

    traxx2003 Member

    111
    6
    1
    Mar 30, 2015
    California
    Posted by traxx2003, Apr 17, 2015 #4
    Update: finally resolved my OSD/no video problem, it was a bad OSD module, got a replacement module from cb helicopter.com, problem solved.
     
Loading...

Share This Page

Loading...