Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

F3 Evo Fried, Again?

Discussion in 'Racer Technical Discussions' started by SMENN, Jul 26, 2018.

  1. SMENN

    SMENN New Member

    1
    0
    0
    Jul 26, 2018
    the world
    Posted by SMENN, Jul 26, 2018 #1
    Hey Everyone, I judt built my first racing drone (micro fpv). I am using the SPRACING F3 EVO, and I am on my second one now, each one has worked well for a short period of time, (10 flights?) and then randomly emits a curl of smoke, and dies completely. If I plug a battery in it smokes again right near where my battery wires are soldered to the board. If I connect to beta flight using USB everything works fine, but battery voltage reads 0 v even when plugged in. AM I doing something wrong? Is there a way to fix? I have surveyed the entire board with a microscope and found nothing as far as a visible bridge between two points.

    Heres the receiver I'm using on UART 2: https://www.amazon.com/gp/product/B01M75FQIO/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1
     
    Tags:
  2. DroneTalk

    DroneTalk R/C Expert Staff Member

    469
    42
    11
    Jul 8, 2015
    new jersey
    Posted by DroneTalk, Jul 31, 2018 #2
    Bad soldering? Can you post some pics?
     
  3. Christian Rogers

    Christian Rogers Member

    98
    15
    1
    Jul 26, 2018
    United States
    Posted by Christian Rogers, Aug 6, 2018 #3
    Pretty sure that there is a short circuit on the board.
     
Loading...

Share This Page

Loading...