Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

Problem with ESCs

Discussion in 'Beginners Drone Forum' started by orobsonpires, Jun 23, 2017.

Tags:
  1. orobsonpires

    orobsonpires New Member

    1
    0
    1
    Jun 23, 2017
    Kiel, Germany
    Posted by orobsonpires, Jun 23, 2017 #1
    Hi everyone,

    I just built my first quadcopter and I am facing a problem with ESCs, I'm using T-Motor F30A ESCs. I tried to calibrate them but nothing happens, they start beeping however the motors are not spinning. I tried to read the escs using the BLHeli Configurator, but the app are not able to read the them. I tested the same with others escs and it worked fine. (newbie question) What to check/do on this situation?
    Please let me know if you need more information.
     
    Tags:
  2. Hi-Flyer

    Hi-Flyer Member

    9
    1
    1
    Jan 27, 2017
    Singapore
    Posted by Hi-Flyer, Jun 25, 2017 #2
    Hi There! First and foremost what FC are you using. Have you tried configuring settings in your Flight controller. If you are using anything related to dji or Naza, BLHeli has issues with it and only Simon K will work (Not sure if this has been solved). Could you send over pictures of your build (including that of your fc) it could be something simple as positioning your fc in the wrong direction.

    Cheers!
    FT Flyer

    Sent from my SM-G570Y using Tapatalk
     
Loading...

Share This Page

Loading...