Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

No transmitter inputs appearing on Cleanflight for new build. Taranis X9, via X8 to Acro Naze32 v6

Discussion in 'Beginners Drone Forum' started by Pauli 336, Sep 30, 2016.

  1. Pauli 336

    Pauli 336 Member

    20
    1
    1
    Sep 27, 2016
    N Ireland
    Posted by Pauli 336, Sep 30, 2016 #1
    Hi,

    I have been reading studying and pouring over articles and videos for weeks prior to my parts arriving, and I have just started putting the electronics together for testing.
    I am using the Turnigy X9rPlus, to the FrSky X8r and Acro Naze32 v6 FC. All are new.
    I am running Cleanflight and Baseflight via iMac.
    I cannot get any inputs to the Turnigy registering on either CF or BF.

    I will run through what I have done so far.
    Set up the X9r according to the manual. Set up a new model and set to D18 Ch 1-8.
    Powered up the X8r and paired successfully with solid green light. So far so good.

    I have connected one motor and Esc and connected to the Naze32 to provide power. After messing about with various USB connectors I got one that worked and made connection to cleanflight.

    Wanting to connect via SBUS to eventually have access to more than 8 channels, I ran a cable from ground, power and signal, to ground power and pin 4 UART2 on the naze32, which I believe is correct for an SBUS setup. So far so good. Turnigy and X8 paired, X* and Naze32 connected in SBUS, and Cleanflight opening port and reading the Naze, as I can move the board about and quad image on CF moves about etc. This is where my issues begin.

    I have calibrated the Accelerometeron the setup page. Then, on the Ports page, I run into problem one.
    UART1 is appearing switched on by default. I then switch on UART2 at 11500 baud and Serial RX. When I save, the switched for UART2 and Serial RX bothe revert to off. I cannot get this setting to stick. If i select UART2 and save its fine, but UART2 and Serial RX together will not save. (I read that the Serial RX must be on for UART2?) This may be the core of my problem but moving on

    In Configuration, I set mixer for Hex X as that is what I am building. I select Receiver mode as RX_Serial, and in the Serial receiver Provider box I select SBUS. Thats all I set then try to save.
    The Sbus line stays the same in the Provider box, but the Receiver mode shows nothing selected?
    In Modes, I have set a switch on the X9 as the arm switch but not sure how to set it up in the mode section of cleanflight. I any event, its not arming and the switch shows no reaction on CF.
    If I go to Motors, I have motor control from the Cleanflight sliders.
    However, when I go to Receiver and move the joysticks around on the X9, nothing happens.

    This is what I am seeing

    Screen Shot 2016-09-30 at 12.42.28.png

    I should add that the Naze 32 has been acting a bit strange (I think!) When I power it up the blue light is steady, and the Green light flashes, which I think is normal. However, on quire a few occasions when connected to CF, and particularly if connected to CF and one ESC at the same time, it seems to freeze. CF cannot read the Naze, and there is a solid green and red light along with the blue one. It has done this at least a dozen times while working on this yesterday. Sometimes disconnecting and reconnecting gets it going again for a while. On 3 occasions it would not come on properly and I had to use the firmware flasher on CF. I have also tried with 2 or 3 different firmware versions (all pretty recent) but its still doing this. I am concerned if this locks up like that in flight.

    So can anyone offer advice on this? I haven't tried via pin to pin connection rather than SBUS, but this has me tearing my hair out. Every video I have watched makes the process look very easy, and I am wondering is there a step I am missing, or a wrong connection, or an issue with this NAze32.

    Thanks
     
    Tags:
  2. moonpie57108

    moonpie57108 Member

    136
    14
    1
    May 21, 2016
    South Dakota
    Posted by moonpie57108, Oct 1, 2016 #2
    I think the UART reverting is your problem, will take a screen shot of mine when I get to a computer. Make sure you are also selecting the correct receiver type on the configurator tab. There is a selector for serial rx and then you pick your type, I think if you skip this step first, the UART2 change to serial rx is basically rejected. First time I setup a spek satellite it taught me like this. So check config tab, same tab you set throttle min/max, board rotation, misc.
     
  3. Pauli 336

    Pauli 336 Member

    20
    1
    1
    Sep 27, 2016
    N Ireland
    Posted by Pauli 336, Oct 1, 2016 #3
    Thanks for checking. I have a new Naze32 on the way, as I think this one is faulty to add to the issues. Too many freezes for me to be comfortable adding it to a build. I'll try what you say when I get it next week, but Im sure I selected the receiver type first as you say.
     
  4. phillip1993

    phillip1993 Member

    15
    0
    1
    Sep 4, 2016
    GB
    Posted by phillip1993, Oct 1, 2016 #4
    Have you tryed re flashing CF
     
  5. Pauli 336

    Pauli 336 Member

    20
    1
    1
    Sep 27, 2016
    N Ireland
    Posted by Pauli 336, Oct 1, 2016 #5
    Hi Phillip. All I have done was flash the latest firmware from within CF to the Naze. What do you mean by reflash C
    Cleanflight?
     
Loading...

Share This Page

Loading...