Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

Motors at idle up to 50% throttle...how to fix?

Discussion in 'DJI NAZA flight control system' started by stevemaller, Jul 16, 2014.

  1. stevemaller

    stevemaller Heavy Lifter

    311
    68
    0
    Oct 19, 2012
    Half Moon Bay, CA
    Posted by stevemaller, Jul 16, 2014 #1
    I am building this copter, and flew it for the first time yesterday:
    http://www.multirotorforums.com/showthread.php?20678-Airsight-4-A-Strong-Shouldered-Quad

    This is my first foray into Naza land. I'm an experienced Mikrokopter guy.

    Of note is that while the copter flew OK for a maiden, I have to move the throttle on the DX8 up to about 50% before the motors move above idle. Obviously this isn't ideal. Once up there, the copter actually handles remarkably well considering I haven't touched the gains or anything else after setting up with all the defaults.

    The copter is using Avroto 3515 motors with the new KDE 35A ESCs and a 6S LiPo, Naza M V2 and Spektrum DX8 and AR8000. I have the radio set up to use the dial on the DX8 to adjust gains, although I haven't associated it with any gains. Should I just attach it to the throttle gain?

    Thanks!
     
    Tags:
  2. flitelab

    flitelab Member

    256
    2
    0
    Jul 13, 2012
    Halifax NS, Canada
    Posted by flitelab, Jul 16, 2014 #2
    That is how NAZA works, its to aide in takeoff so that people weren't easing into throttle and sticking in ground effect.

    Only manual mode will give you direct linear throttle.
     
    Last edited by a moderator: Jul 16, 2014
  3. Benjamin Kenobi

    Benjamin Kenobi Easy? You call that easy?

    2,179
    70
    31
    Jun 22, 2012
    The Cotswolds, England
    Posted by Benjamin Kenobi, Jul 16, 2014 #3
    Yep, normal behaviour.
     
  4. stevemaller

    stevemaller Heavy Lifter

    311
    68
    0
    Oct 19, 2012
    Half Moon Bay, CA
    Posted by stevemaller, Jul 16, 2014 #4
    Thanks! Kinda weird, but OK. ;-)

    OK, so another related question: my mode switch toggles between Atti, Atti/GPS and Failsafe. I think that's how I set it up by removing the binding plug during binding. If I re-do the binding without doing that, will that upper position change from Failsafe to Manual mode? Otherwise I don't see how to get into Manual mode.
     
  5. flitelab

    flitelab Member

    256
    2
    0
    Jul 13, 2012
    Halifax NS, Canada
    Posted by flitelab, Jul 16, 2014 #5
    You set what mode you want the bottom position to be in the assistant software. The right most/bottom item lets you select if its failsafe or manual when in that position.

    Failsafe for the Rx is a different setting based on how your bound the receiver and where NAZA was set at that time.
     
  6. stevemaller

    stevemaller Heavy Lifter

    311
    68
    0
    Oct 19, 2012
    Half Moon Bay, CA
    Posted by stevemaller, Jul 16, 2014 #6
    Thank you!
    I find the documentation to be sorely lacking for this.
    Is there a good writeup or video somewhere that walks through the various configuration options and procedures?
     
  7. Benjamin Kenobi

    Benjamin Kenobi Easy? You call that easy?

    2,179
    70
    31
    Jun 22, 2012
    The Cotswolds, England
    Posted by Benjamin Kenobi, Jul 16, 2014 #7
    Once again, flitelab has got it perfect as usual.
     
Loading...

Share This Page

Loading...