Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

F450 Quad Unstable Flight Problem

Discussion in 'Drone Builds and Kits' started by Coldplayerdem, Apr 2, 2018.

  1. Coldplayerdem

    Coldplayerdem New Member

    2
    0
    1
    Apr 2, 2018
    Kadikoi
    Posted by Coldplayerdem, Apr 2, 2018 #1
    Hello,

    I have a problem about my new-build f450 quad and asking for your help.
    First things first; let me write my setup;

    *Frame : DJI F450
    *Flight Controller: DJI Naza V2
    *ESC: Dalrc Engine 4in1 40A
    *Motors: Sunnysky V2806 (650KV)
    *Battery: ZOP Power 4S 6300mah 35C
    *Props: 1240 Carbon Props

    Here is my problem;
    When I fully charged my 4S Lipo battery to maximum; It hovers and flies without a problem for first couple of minutes. After a little bit voltage reduce (maybe 0.5V) it starts to tilting & drifting & losing stability. This problem gets bigger if I continue to fly, and about 3-4 minutes later drone can not stand stable and crash. Then right after that, if I plug in another fully charged battery; it flies again for 1-2 minutes, and after that it happens again and again and again.
    If I plug half-charged battery, it never flies stable.

    My notes:
    Esc's are calibrated well.
    Motors & props easilly turn, no tightens,
    Emi shilding is okay with copper tape.
    Gains are default DJI naza gains (maybe I need to change it a bit)
    Motors, esc, naza is stay cold during flight (no overheat)
    Setup also been tested on ecalc many many times, ecalc says everything is working okay, also it should fly about 20-21mins hover

    I have suspicions about a faulty ESC but it flies for 1-2 minutes well. Problem occures after that.
    I have also suspicions about a fake C rate on battery; but a "hovering" dont use a lot of current, it can not even hover stable after 2-3 mins flight.

    So I can not solve this problem. Could you please help me?

    Thank you.
     
  2. Troy_Forman

    Troy_Forman Member

    10
    1
    1
    Apr 16, 2018
    Grimshaw
    Posted by Troy_Forman, May 8, 2018 #2
    If you used two battery’s and nothing changed I would say it is your esc is faulty


    Sent from my iPad using Tapatalk
     
  3. Chris Harris

    Chris Harris New Member

    2
    0
    1
    Aug 7, 2015
    alabama
    Posted by Chris Harris, Sep 22, 2019 #3
    Hey man I am having the same problem with these motors .I know for a fact it is the motors as I was using rimfire 10 s ony setup before these sunnysky 2806 and my 450 flew great .I'm running naza wookong on a tbs discovery that is stretched out .Tarannis x8r and castle quadpack 35 escs .I have had no luck with straightening out the bad flight problems I'm probably gonna put my rimfire motors back on as it was flying great with them .btw I tried these motors on 3 s 4000 mAh, 4 s 2800 mAh and 5 s 1500 mAh.with no good results. gonna try a couple more things and if no better these 2806 are going back .but I don't think it's your escs.as I am having this issue also verbatim as to what your having.feel free to hit me up.
     
  4. Coldplayerdem

    Coldplayerdem New Member

    2
    0
    1
    Apr 2, 2018
    Kadikoi
    Posted by Coldplayerdem, Sep 23, 2019 #4
    hello friend, meanwhile i have solved this problem. it was about the esc settings. I use blheli, i connected it to pc and opened blheli suite. there was a setting called "ramp up power" . it was set to %50 by default. this setting was about the motor acceleration ratio. i increased it to %100 and the problem is solved. my problem was about "slow accelerating motors" and drone was flying like drunk. Now its totally gone. ı hope it helps :)
     
Loading...

Share This Page

Loading...