Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

CC3D vs. 3DR Radio vs. RDF900+ Radio

Discussion in 'Recreational sUAS Flyers Discussions' started by Not_Sure, Jun 10, 2016.

  1. Not_Sure

    Not_Sure Member

    10
    0
    1
    Jun 10, 2016
    USA
    Posted by Not_Sure, Jun 10, 2016 #1
    Hi All,

    I have an interesting challenge. The back-story is that I paired a new CC3D with an existing pair of 3DR radios. They worked perfectly, right from the start. No configuration required. After the first flight with this hardware I found that I no longer had telemetry. One of the radios had failed. I replaced it with a RFD900+, since that would make a good ground station radio, compatible with another project.

    Where I'm at now is that I can use Mission Planner Initial Config and find both radios. I can load and save settings. The two radios go solid green as though they are connected. However, when I try to "Connect" with Mission Planner, it times out with a no heartbeat packets error.

    My questions to the community are:
    Any suggestions on what I might be missing?
    Is there special firmware to use 3DR radios with CC3D?

    Many thanks for any help!

    Chris
     
  2. Not_Sure

    Not_Sure Member

    10
    0
    1
    Jun 10, 2016
    USA
    Posted by Not_Sure, Jun 10, 2016 #2
    A little more detail - The remote radio appears to be chattering away. The red LED flashes with lots of activity. The local end shows no red activity, just a solid green link.
     
  3. Not_Sure

    Not_Sure Member

    10
    0
    1
    Jun 10, 2016
    USA
    Posted by Not_Sure, Jun 10, 2016 #3
    Solved my own problem. I need to use OpenPilotGCS. Works great! :rolleyes:
     
  4. violetwolf

    violetwolf Member

    617
    155
    26
    Apr 9, 2013
    Posted by violetwolf, Jun 11, 2016 #4
    Also the baud rate needs to be set differently for USB vs radios when connecting Mission Planner.. This one bites me every time lol
     
  5. Not_Sure

    Not_Sure Member

    10
    0
    1
    Jun 10, 2016
    USA
    Posted by Not_Sure, Jun 12, 2016 #5
    Yeah. Thanks. I did forget about that too. Bigger problems now though. New thread!
     
Loading...

Share This Page

Loading...