Welcome To DroneVibes

DroneVibes is a COMMUNITY of drones enthusiasts. We are experts at drones for all professional and consumer applications. We welcome you to register and join the conversation.

4 Mini OSD's and none of them work!!

Discussion in 'DJI NAZA flight control system' started by tomb18, Apr 17, 2016.

  1. tomb18

    tomb18 Member

    30
    0
    0
    Mar 28, 2015
    Canada
    Posted by tomb18, Apr 17, 2016 #1
    So, I have a Naza V2 flight controller and I bought a Mini OSD controller. I hooked it all up and there was no output of OSD data. So I did an RMA but to save time I bought another one.
    Guess what, same thing! So I sent it back, and DJI returned after 3 months, both of them under warantee repair.
    Guess what, both do not work!
    So what is going on? I am using the latest firmware, on the Naza, I am using a ready made RC NTSC camera. I have tried two different monitors and never any OSD.
    Is there something I have to enable in the firmware? What is going on?
    I have done searches and I have found many threads where the OSD's were not working. RMA usually fixed this up.
    Do I need to scrap the whole NAZA and move to a PixHalk?
    Help!
     
    Tags:
  2. tomb18

    tomb18 Member

    30
    0
    0
    Mar 28, 2015
    Canada
    Posted by tomb18, Apr 20, 2016 #2
    I can't believe this. No one will help!
    Not only that, a post on DJI's forum was just deleted with no replies.
    Isn't anyone using a DJI Mini OSD successfully?
     
  3. Posted by John Doecliff, Apr 20, 2016 #3
    I have 2 and they both work fine. I have heard someone comment that they have a high failure rate and a lot of them that ship do not work but its hard to believe you got 4 of them. Are you absolutely certain you have it wired up right? I had to make a custom wire harness for mine.
     
    jahatton likes this.
  4. tomb18

    tomb18 Member

    30
    0
    0
    Mar 28, 2015
    Canada
    Posted by tomb18, Apr 20, 2016 #4
    I triple checked the harness. Been doing electronics all my life (I'm 58) (design too).
    I don't believe DJI even tested them or looked at them at the factory. It took three months and after I complained twice and then mentioned a youtube video, it was returned the next day. One new one, untested, and the original one not repaired.
    I posted the follow up at DJI forums and they deleted the forum post.
    I also tried a different PMU. It made no difference.
    The harness is correct. The video is powered, the transmitter is powered, the video works and it goes in and then out of the miniOSD. Everything looks good but no OSD.
     
  5. Alwil

    Alwil Member

    99
    33
    11
    Mar 23, 2015
    Virginia
    Posted by Alwil, Apr 20, 2016 #5
    I don't know what to even tell you. I have 3 currently on different multirotors and all
    work fine. With the video passing thru- it has to be internal. I have never pulled one apart.
    Really makes you wonder.
     
  6. Posted by John Doecliff, Apr 21, 2016 #6
    Yes if your putting video in and getting it out but no OSD it sounds like you got defective ones. That sucks that you had rotten luck.
     
  7. AirShooter

    AirShooter FlyCam UAV

    96
    8
    1
    Aug 12, 2014
    Chatsworth, CA
    Posted by AirShooter, Jun 23, 2016 #7
    Have you checked to be sure your video TX is working??
     
  8. jahatton

    jahatton Member

    13
    0
    1
    May 14, 2014
    Hope BC Canada
    Posted by jahatton, Aug 18, 2016 #8
    Sorry to hear of your situation. Mine Mini OSD worked from day one (NAZA M V2)
     
  9. calvin baker jr

    calvin baker jr New Member

    3
    0
    1
    Dec 6, 2019
    Louisiana
    Posted by calvin baker jr, Dec 6, 2019 #9
    Im using the N2 OSD with the Naza M Lite and Ive not had any major issues except I cant monitor voltage. Which particular OSD are you using and are you plugged into the F1 green and F2 blue om the bottom pins?
     
Loading...

Share This Page

Loading...